易语言计算列表框项目文本内数值的总和

京东电脑馆,潮玩好物集

​代码和效果截图

图片[1]-易语言计算列表框项目文本内数值的总和-不凡博客(Bufanz.com)

代码

.版本 2
.局部变量 i, 整数型
.局部变量 数值, 整数型
.局部变量 总和, 整数型
.计次循环首 (列表框1.取项目数 (), i)
数值 = 到数值 (列表框1.取项目文本 (i - 1))
总和 = 总和 + 数值
.计次循环尾 ()
标签1.标题 = 到文本 (总和)

列表框的项目文本内的数值有小数,比如计算的是金额,有角有分,数值、总和的变量类型改成小数型,超级列表框也同理。

淘宝购物先领券,更省钱
© 版权声明
THE END
喜欢就支持一下吧
点赞0赞赏
评论 抢沙发

请登录后发表评论