易语言通过注册表读取程序的路径

京东电脑馆,潮玩好物集

教程简介

  Windows平台的程序在运行的时候会在注册表添加程序的路径,在易语言可以通过注册表读取程序的路径。

  注册表路径:HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache

图片[1]-易语言通过注册表读取程序的路径-不凡博客(Bufanz.com)

程序的描述

图片[2]-易语言通过注册表读取程序的路径-不凡博客(Bufanz.com)

根据程序描述返回路径的代码

以下代码需要引用精易模块:http://ec.125.la/

.版本 2
.子程序 根据程序描述返回路径, 文本型
.参数 程序描述, 文本型
.局部变量 注册表操作, 注册表操作
.局部变量 键名数组, 文本型, , "0"
.局部变量 键值数组, 字节集, , "0"
.局部变量 i, 整数型
.局部变量 返回值, 文本型
.计次循环首 (注册表操作.枚举键名 (“HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache”, 键名数组, 键值数组, ), i)
.如果真 (到文本 (键值数组 [i]) = 程序描述)
返回值 = 返回值 + 键名数组 [i]
.如果真结束
.计次循环尾 ()
返回 (返回值)

实例代码

编辑框1.内容 = 根据程序描述返回路径 (“WeChat”)

效果截图

图片[3]-易语言通过注册表读取程序的路径-不凡博客(Bufanz.com)
淘宝购物先领券,更省钱
© 版权声明
THE END
喜欢就支持一下吧
点赞0赞赏
评论 抢沙发

请登录后发表评论